1 | Summary: Library providing XML and HTML support
|
---|
2 | Name: libxml2
|
---|
3 | Version: 2.9.2
|
---|
4 | Release: 1%{?dist}%{?extra_release}
|
---|
5 | License: MIT
|
---|
6 | Group: Development/Libraries
|
---|
7 | Source: ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
|
---|
8 | BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
---|
9 | BuildRequires: python python-devel zlib-devel pkgconfig xz-devel
|
---|
10 | URL: http://xmlsoft.org/
|
---|
11 |
|
---|
12 | %description
|
---|
13 | This library allows to manipulate XML files. It includes support
|
---|
14 | to read, modify and write XML and HTML files. There is DTDs support
|
---|
15 | this includes parsing and validation even with complex DtDs, either
|
---|
16 | at parse time or later once the document has been modified. The output
|
---|
17 | can be a simple SAX stream or and in-memory DOM like representations.
|
---|
18 | In this case one can use the built-in XPath and XPointer implementation
|
---|
19 | to select sub nodes or ranges. A flexible Input/Output mechanism is
|
---|
20 | available, with existing HTTP and FTP modules and combined to an
|
---|
21 | URI library.
|
---|
22 |
|
---|
23 | %package devel
|
---|
24 | Summary: Libraries, includes, etc. to develop XML and HTML applications
|
---|
25 | Group: Development/Libraries
|
---|
26 | Requires: libxml2 = %{version}-%{release}
|
---|
27 | Requires: zlib-devel
|
---|
28 | Requires: xz-devel
|
---|
29 | Requires: pkgconfig
|
---|
30 |
|
---|
31 | %description devel
|
---|
32 | Libraries, include files, etc you can use to develop XML applications.
|
---|
33 | This library allows to manipulate XML files. It includes support
|
---|
34 | to read, modify and write XML and HTML files. There is DTDs support
|
---|
35 | this includes parsing and validation even with complex DtDs, either
|
---|
36 | at parse time or later once the document has been modified. The output
|
---|
37 | can be a simple SAX stream or and in-memory DOM like representations.
|
---|
38 | In this case one can use the built-in XPath and XPointer implementation
|
---|
39 | to select sub nodes or ranges. A flexible Input/Output mechanism is
|
---|
40 | available, with existing HTTP and FTP modules and combined to an
|
---|
41 | URI library.
|
---|
42 |
|
---|
43 | %package static
|
---|
44 | Summary: Static library for libxml2
|
---|
45 | Group: Development/Libraries
|
---|
46 | Requires: libxml2 = %{version}-%{release}
|
---|
47 |
|
---|
48 | %description static
|
---|
49 | Static library for libxml2 provided for specific uses or shaving a few
|
---|
50 | microseconds when parsing, do not link to them for generic purpose packages.
|
---|
51 |
|
---|
52 | %package python
|
---|
53 | Summary: Python bindings for the libxml2 library
|
---|
54 | Group: Development/Libraries
|
---|
55 | Requires: libxml2 = %{version}-%{release}
|
---|
56 |
|
---|
57 | %description python
|
---|
58 | The libxml2-python package contains a module that permits applications
|
---|
59 | written in the Python programming language to use the interface
|
---|
60 | supplied by the libxml2 library to manipulate XML files.
|
---|
61 |
|
---|
62 | This library allows to manipulate XML files. It includes support
|
---|
63 | to read, modify and write XML and HTML files. There is DTDs support
|
---|
64 | this includes parsing and validation even with complex DTDs, either
|
---|
65 | at parse time or later once the document has been modified.
|
---|
66 |
|
---|
67 | %prep
|
---|
68 | %setup -q
|
---|
69 |
|
---|
70 | %build
|
---|
71 | %configure
|
---|
72 | make %{_smp_mflags}
|
---|
73 |
|
---|
74 | %install
|
---|
75 | rm -fr %{buildroot}
|
---|
76 |
|
---|
77 | make install DESTDIR=%{buildroot}
|
---|
78 |
|
---|
79 | rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
---|
80 | rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.a
|
---|
81 | rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.la
|
---|
82 | rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/libxml2-%{version}/*
|
---|
83 | rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/libxml2-python-%{version}/*
|
---|
84 | (cd doc/examples ; make clean ; rm -rf .deps Makefile)
|
---|
85 | gzip -9 -c doc/libxml2-api.xml > doc/libxml2-api.xml.gz
|
---|
86 |
|
---|
87 | %check
|
---|
88 | make runtests
|
---|
89 |
|
---|
90 | %clean
|
---|
91 | rm -fr %{buildroot}
|
---|
92 |
|
---|
93 | %post -p /sbin/ldconfig
|
---|
94 |
|
---|
95 | %postun -p /sbin/ldconfig
|
---|
96 |
|
---|
97 | %files
|
---|
98 | %defattr(-, root, root)
|
---|
99 |
|
---|
100 | %doc AUTHORS NEWS README Copyright TODO
|
---|
101 | %doc %{_mandir}/man1/xmllint.1*
|
---|
102 | %doc %{_mandir}/man1/xmlcatalog.1*
|
---|
103 | %doc %{_mandir}/man3/libxml.3*
|
---|
104 |
|
---|
105 | %{_libdir}/lib*.so.*
|
---|
106 | %{_bindir}/xmllint
|
---|
107 | %{_bindir}/xmlcatalog
|
---|
108 |
|
---|
109 | %files devel
|
---|
110 | %defattr(-, root, root)
|
---|
111 |
|
---|
112 | %doc %{_mandir}/man1/xml2-config.1*
|
---|
113 | %doc AUTHORS NEWS README Copyright
|
---|
114 | %doc doc/*.html doc/html doc/*.gif doc/*.png
|
---|
115 | %doc doc/tutorial doc/libxml2-api.xml.gz
|
---|
116 | %doc doc/examples
|
---|
117 | %doc %dir %{_datadir}/gtk-doc/html/libxml2
|
---|
118 | %doc %{_datadir}/gtk-doc/html/libxml2/*.devhelp
|
---|
119 | %doc %{_datadir}/gtk-doc/html/libxml2/*.html
|
---|
120 | %doc %{_datadir}/gtk-doc/html/libxml2/*.png
|
---|
121 | %doc %{_datadir}/gtk-doc/html/libxml2/*.css
|
---|
122 |
|
---|
123 | %{_libdir}/lib*.so
|
---|
124 | %{_libdir}/*.sh
|
---|
125 | %{_includedir}/*
|
---|
126 | %{_bindir}/xml2-config
|
---|
127 | %{_datadir}/aclocal/libxml.m4
|
---|
128 | %{_libdir}/pkgconfig/libxml-2.0.pc
|
---|
129 | %{_libdir}/cmake/libxml2/libxml2-config.cmake
|
---|
130 |
|
---|
131 | %files static
|
---|
132 | %defattr(-, root, root)
|
---|
133 |
|
---|
134 | %{_libdir}/*a
|
---|
135 |
|
---|
136 | %files python
|
---|
137 | %defattr(-, root, root)
|
---|
138 |
|
---|
139 | %{_libdir}/python*/site-packages/libxml2.py*
|
---|
140 | %{_libdir}/python*/site-packages/drv_libxml2.py*
|
---|
141 | %{_libdir}/python*/site-packages/libxml2mod*
|
---|
142 | %doc python/TODO
|
---|
143 | %doc python/libxml2class.txt
|
---|
144 | %doc python/tests/*.py
|
---|
145 | %doc doc/*.py
|
---|
146 | %doc doc/python.html
|
---|
147 |
|
---|
148 | %changelog
|
---|
149 | * Thu Oct 16 2014 Daniel Veillard <[email protected]>
|
---|
150 | - upstream release 2.9.2 see http://xmlsoft.org/news.html
|
---|
151 |
|
---|