VirtualBox

source: vbox/trunk/src/libs/libxml2-2.9.4/libxml2.spec@ 70563

最後變更 在這個檔案從70563是 65950,由 vboxsync 提交於 8 年 前

libxml 2.9.4: fix export

  • 屬性 svn:eol-style 設為 native
檔案大小: 5.9 KB
 
1%global with_python3 1
2
3Summary: Library providing XML and HTML support
4Name: libxml2
5Version: 2.9.4
6Release: 1%{?dist}%{?extra_release}
7License: MIT
8Group: Development/Libraries
9Source: ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: python-devel
12%if 0%{?with_python3}
13BuildRequires: python3-devel
14%endif # with_python3
15BuildRequires: zlib-devel
16BuildRequires: pkgconfig
17BuildRequires: xz-devel
18URL: http://xmlsoft.org/
19
20%description
21This library allows to manipulate XML files. It includes support
22to read, modify and write XML and HTML files. There is DTDs support
23this includes parsing and validation even with complex DtDs, either
24at parse time or later once the document has been modified. The output
25can be a simple SAX stream or and in-memory DOM like representations.
26In this case one can use the built-in XPath and XPointer implementation
27to select sub nodes or ranges. A flexible Input/Output mechanism is
28available, with existing HTTP and FTP modules and combined to an
29URI library.
30
31%package devel
32Summary: Libraries, includes, etc. to develop XML and HTML applications
33Group: Development/Libraries
34Requires: libxml2 = %{version}-%{release}
35Requires: zlib-devel
36Requires: xz-devel
37Requires: pkgconfig
38
39%description devel
40Libraries, include files, etc you can use to develop XML applications.
41This library allows to manipulate XML files. It includes support
42to read, modify and write XML and HTML files. There is DTDs support
43this includes parsing and validation even with complex DtDs, either
44at parse time or later once the document has been modified. The output
45can be a simple SAX stream or and in-memory DOM like representations.
46In this case one can use the built-in XPath and XPointer implementation
47to select sub nodes or ranges. A flexible Input/Output mechanism is
48available, with existing HTTP and FTP modules and combined to an
49URI library.
50
51%package static
52Summary: Static library for libxml2
53Group: Development/Libraries
54Requires: libxml2 = %{version}-%{release}
55
56%description static
57Static library for libxml2 provided for specific uses or shaving a few
58microseconds when parsing, do not link to them for generic purpose packages.
59
60%package python
61Summary: Python bindings for the libxml2 library
62Group: Development/Libraries
63Requires: libxml2 = %{version}-%{release}
64
65%description python
66The libxml2-python package contains a Python 2 module that permits applications
67written in the Python programming language, version 2, to use the interface
68supplied by the libxml2 library to manipulate XML files.
69
70This library allows to manipulate XML files. It includes support
71to read, modify and write XML and HTML files. There is DTDs support
72this includes parsing and validation even with complex DTDs, either
73at parse time or later once the document has been modified.
74
75%if 0%{?with_python3}
76%package python3
77Summary: Python 3 bindings for the libxml2 library
78Group: Development/Libraries
79Requires: libxml2 = %{version}-%{release}
80
81%description python3
82The libxml2-python3 package contains a Python 3 module that permits
83applications written in the Python programming language, version 3, to use the
84interface supplied by the libxml2 library to manipulate XML files.
85
86This library allows to manipulate XML files. It includes support
87to read, modify and write XML and HTML files. There is DTDs support
88this includes parsing and validation even with complex DTDs, either
89at parse time or later once the document has been modified.
90%endif # with_python3
91
92%prep
93%setup -q
94
95%build
96%configure
97make %{_smp_mflags}
98
99%install
100rm -fr %{buildroot}
101
102make install DESTDIR=%{buildroot}
103
104%if 0%{?with_python3}
105make clean
106%configure --with-python=%{__python3}
107make install DESTDIR=%{buildroot}
108%endif # with_python3
109
110
111rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
112rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.a
113rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.la
114rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/libxml2-%{version}/*
115rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/libxml2-python-%{version}/*
116(cd doc/examples ; make clean ; rm -rf .deps Makefile)
117gzip -9 -c doc/libxml2-api.xml > doc/libxml2-api.xml.gz
118
119%check
120make runtests
121
122%clean
123rm -fr %{buildroot}
124
125%post -p /sbin/ldconfig
126
127%postun -p /sbin/ldconfig
128
129%files
130%defattr(-, root, root)
131
132%doc AUTHORS NEWS README Copyright TODO
133%doc %{_mandir}/man1/xmllint.1*
134%doc %{_mandir}/man1/xmlcatalog.1*
135%doc %{_mandir}/man3/libxml.3*
136
137%{_libdir}/lib*.so.*
138%{_bindir}/xmllint
139%{_bindir}/xmlcatalog
140
141%files devel
142%defattr(-, root, root)
143
144%doc %{_mandir}/man1/xml2-config.1*
145%doc AUTHORS NEWS README Copyright
146%doc doc/*.html doc/html doc/*.gif doc/*.png
147%doc doc/tutorial doc/libxml2-api.xml.gz
148%doc doc/examples
149%doc %dir %{_datadir}/gtk-doc/html/libxml2
150%doc %{_datadir}/gtk-doc/html/libxml2/*.devhelp
151%doc %{_datadir}/gtk-doc/html/libxml2/*.html
152%doc %{_datadir}/gtk-doc/html/libxml2/*.png
153%doc %{_datadir}/gtk-doc/html/libxml2/*.css
154
155%{_libdir}/lib*.so
156%{_libdir}/*.sh
157%{_includedir}/*
158%{_bindir}/xml2-config
159%{_datadir}/aclocal/libxml.m4
160%{_libdir}/pkgconfig/libxml-2.0.pc
161%{_libdir}/cmake/libxml2/libxml2-config.cmake
162
163%files static
164%defattr(-, root, root)
165
166%{_libdir}/*a
167
168%files python
169%defattr(-, root, root)
170
171%{_libdir}/python2*/site-packages/libxml2.py*
172%{_libdir}/python2*/site-packages/drv_libxml2.py*
173%{_libdir}/python2*/site-packages/libxml2mod*
174%doc python/TODO
175%doc python/libxml2class.txt
176%doc python/tests/*.py
177%doc doc/*.py
178%doc doc/python.html
179
180%if 0%{?with_python3}
181%files python3
182%defattr(-, root, root)
183
184%{_libdir}/python3*/site-packages/libxml2.py*
185%{_libdir}/python3*/site-packages/drv_libxml2.py*
186%{_libdir}/python3*/site-packages/__pycache__/libxml2.cpython-34.py*
187%{_libdir}/python3*/site-packages/__pycache__/drv_libxml2.cpython-34.py*
188%{_libdir}/python3*/site-packages/libxml2mod*
189%doc python/TODO
190%doc python/libxml2class.txt
191%doc python/tests/*.py
192%doc doc/*.py
193%doc doc/python.html
194%endif # with_python3
195
196%changelog
197* Mon May 23 2016 Daniel Veillard <[email protected]>
198- upstream release 2.9.4 see http://xmlsoft.org/news.html
199
注意: 瀏覽 TracBrowser 來幫助您使用儲存庫瀏覽器

© 2024 Oracle Support Privacy / Do Not Sell My Info Terms of Use Trademark Policy Automated Access Etiquette